Distributions

Articles de cette rubrique

  • Les plugins "Core"

    , par James

    L’intégration de Composer dans la gestion des plugins de la distribution "Classic" de SPIP est le problème technique le plus complexe à résoudre. La question de leur installation a été réglé grâce à L’installeur Composer pour SPIP. Toutefois, pour qu’un dépôt Composer puisse être mis à jour à chaque (...)

  • Les versions "Classic" 3.0, 3.1 et 3.2

    , par James

    Même si le nom de cette distribution n’est pas définitif, on entend, dans le cadre de cette démonstration, par "Classic" la distribution historique de SPIP.
    Elle comprend l’espace privé, accessible via le répertoire physique ./ecrire qui contient aussi les mécanismes de base du CMS, et dont (...)

  • Faire une distribution alternative et conclusion

    , par James

    TL ; DR
    composer create-project geodiv/geodiv Oui, mais encore ?
    PHP>7.1 (spip/cms 3.1.*)
    Le squelette Géodiversité est basé sur SPIP 3.1 qui n’est, au jour où cet article est publié, compatible que jusqu’à PHP 7.1 [1].
    Si vous utilisez une version PHP plus récente :
    composer create-project (...)